CS 150 Lab 01
Introduction to Visual Studio

The purpose of today’s lab session is to familiarize you with
1. Connecting to the Computer Science server ‘grace’ which you will use to turn in your solution
to a given program assignment / lab assignment
2. Visual Studio 2013 Ultimate
3. Building and Running a Program

» If you have trouble with any piece of this, please ask the instructor for help.

» Connect to the Computer Science server grace.cs.pacificu.edu
1. Go to Start and right-click on Computer

Open
Control Panel 'EE' Manage

Map network drive...
Disconnect network drive...

Show on Desktop

Rename

Properties |

2. Select Map network drive
< [

&) % Map Network Drive -

What network folder would you like to map?

Specify the drive letter for the connection and the folder that you want to connect to:

Drive: [T: v]

Folder: Y\grace.cs.pacificu.edu’\students - Browse...

Example: \\server\share

[¥] Reconnect at logon
[ Connect using different credentials

Connect to a Web site that you can use to store your docurments and pictures,

[ Finish ][ Cancel ]

3. Type in \\grace.cs.pacificu.edu\students in the Folder textbox. Do not worry about what Drive
letter is showing. Could be W: or Z: or anything else. Notice the slashes are \ not /.

4. When you are prompted for a name and password, type in eniac\yourloginname
where yourloginname is your PUNetID and the password is your grace password.



5.

If all goes well, you will see something like the following:

e IEw T s < ——
@th—f‘ » Computer » students (\\grace.cs.pacificu.edu) (V2) » - |4¢‘ | """""" j el |
Organize Burn Mew folder =~ O @
¢ Favorites i Name : Date medified Type
Bl Desktop . CS130-01Accts 8/22/2014 2:58 PM File folder
& Downloads , C5130-01Drop 6/27/2014 205PM  Filefolder
5] Recent Places . C5130Public 6/27/2014 2:05 PM File folder
. CS150-01Accts File folder
4 Libraries £ . CS150-01Drop File folder
3 Documents . CS150-02Accts File folder
,—J“- Music . C5150-02Drop File folder
=] Pictures . CS150-03Accts File folder
Subversicn . C5150-03Drop File folder
E Videos . C5150Public File folder
C5300-01 Accts 6/27/2014 2:25 PM File folder
1% Computer C5300-01Drop 6/27/2014 2:24 PM File folder
‘:_i, Local Disk (C:) C5300Public 8/21/2014 2:38 PM File folder
¥ students (1\\64.59.233.203)
# students (\\grace.cs.pacif = [ m -
13 items Offline status: Online
‘4 Offline availability: Not available

6. Inside of CS150-02Accts you will find your individual folder to be used for saving your
projects. No other student has access to this folder, but faculty members do. Do not store any
illegal material on grace.

7. We will come back to grace later in the lab.

» Introduction to Visual Studio 2013 Ultimate

1. Log on to the computer if you have not already done so.

2. Start Visual Studio 2013 Ultimate by using the Start button to navigate to Programs and then
Microsoft Visual Studio 2013

3. We are going to go through creating a solution PUNetIDLabs and your first project
01_1 HelloWorld. Create a new project by going to File> New->Project. Select (Visual C++)
from the left window, and (Win32 Console Application from the main window. For Name: use
01_1 HelloWorld and for Solution name: use PUNetIDLabs where PUNetID is your
PUNEetID. As an example, for a PUNet of khoj0332, the window below would look like the
following:

New Project

b Recent MET Frami

B w

k MFC Application Visual C++
Ea

- Sortby: Default

4 Installed
e Application Visual C++

A pri creating a Win32
application

Visual C++

- Browse...

Create direct

Cancel




4. Once the Name, Location, and Solution name are correct AND Win32 Console Application is
selected, you can click OK, which takes you to the following screen. Make sure the Application
type is Console application.

5. The following window will be displayed. You need to see Console application.
Win32 Application Wizard - 01_1 HelloWorld (2 [

— - ]

Welcome to the Win22 Application Wizard

Qverview These are the current project settings:
Application Settings & Console application
Click Fimish from any window to accept the current settings.

After you create the project, see the project's readme. txt file for information
about the project features and files that are generated.

l Next > H Finish H Cancel I

6. blicking Next results in the following: You are to uncheck Precompiled header and check
Empty Project BEFORE clicking Finish as shown below.



Win32 Application Wizard - 01_1_HelloWorld [ % | &= |

mry  Application Settings

Overview Application type: Add common header files for:

o ) () Windows application
Application Settings -
(®) Console application
(@]1E
() Static library
Additional options:
Empty project

Security Development Lifecyde (SDL)
checks

.

7. Once you have completed step 6, stop and ask the instructor or TA to review your work.

8. Add a New Item to the Project. Right click on the folder Source Files>Add->New Item.... You
will see the window below. Select C++ File (.cpp) and name it main.cpp.

Add New Itern - 01_1_HelloWorld R E
4 Installed Sort by: Default S = Searc 1 Templates (Ctrl+E P~

4 ‘ulsuljll C++ I'—_, C++ File (.cpp) Visual Cit Typ ual C++

Creates a file containing C++ source code

Code Header File (b - s
eade el Vis (
HLsL || eader File (.h) Visual C++

Data

Resource

Web

Utility

Property Sheets
Test

I Online

MName: main.cpp

Location: c\Users\shereen\documentsivisual studio 2013%Projectsikhe -

9. Turn on line numbers and setup the tab size to tab 2:
1. Show Line Numbers
e Tools—>Options—> Text Editor-> All Languages—> General
e Check Line numbers
2. Set Tab Size
e Tools—>Options—> Text Editor->All Languages—> Tabs



1. Tab Size:2
2. Indent Size: 2
3. Check Keep Tabs
10. Type in the following program to main.cpp. Be sure to copy the program exactly as shown
below. Use your name as the Author and use today’s date and change the class to CS150-02.

[J Y6 Quicklau Ctrl+Q m|
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM TOOLS TEST ARCHITECTURE  AMNALYZE  WINDOW Sign in
[« B-akg 9 - P Local Windows Debugger ~ Debug - M & _ M
main.cpp™ 8 X

~ @ main()

xoqoo] J=10| Ij::-ia FELVELS

v
4 o] Source Files
3 main.cpp

= main ()
.

100% =~ 4
Output

Show output from:  Build

Error List Pending Changes Team Expl... Class View
Ready

11. Once you have completed step 9, stop and ask the instructor or TA to review your work.

» Let's examine the program you just wrote.

1. Lines 1-8 are comments. Note that comments are used to explain to the human reader what this
program does. Visual Studio's compiler ignores comment lines. Note that comments are green.

2. Line 10 includes the iostream (input/output stream) library required to display messages to the
screen. The iostream library is also required when reading input from the user.

3. Line 12 specifies the namespace, which is required for using cout to display messages to the
screen. More on this later.

4. Line 14 declares the main function required by every C++ program. The main function is
where every C++ program starts when you begin program execution.

5. Line 15 and 19 contain { and }, respectively. These mark the beginning and ending of ALL
lines that are included in the main function.

6. Line 16 displays a message on the screen.

7. Line 18 ends the program where EXIT_SUCCESS denotes that no runtime errors were
encountered.

» Building the Program
Before you can run your program, you will need to build the program which checks your program for



syntax errors. A program that builds with no syntax errors causes your C++ code to be translated into
machine code (zeros and ones) that is understood by the computer.

1. You are ready to build and run your first C++ Program! Make sure you've saved your work
using File | Save All or the blue disk icon on the tool bar.

2. Build your program using the Build menu and the Build Solution option. Or press the F7 key.
Building the program checks for syntax errors.
The program will then compile and link. The output window below the source window will
display messages indicating what is going on. You can expand this window or scroll through so
that you are able to read all the messages.

If you have typed everything correctly, the window will display Build: 1 succeeded. If you do get
errors, then check your code and make sure you've typed everything correctly. Let me know if you can't
get things to work.

» Run the Program
1. Run your program by using the Debug menu and the Start Without Debugging option.
2. Ablack window should appear.
3. Which lines in your program do you think produces each line in the black output window?
Answer

4. What happens after you press enter? Answer

5. Once you have completed step 4, stop and ask the instructor or TA to review your work.

Congratulations! You have run your first C++ program.
What happens if we type cot instead of cout? Try it now, and build and run your program again.

Answer

What happens if we delete ( << endl ) from line 16? Try it now, and build and run your program again.

Answer

» Once you have completed all of the above, then create a new project in your solution
PUNetIDLabs. You do this by going to File->Add->New Project .. Name this project
01 2 PayCalculator. Make sure that the project is a Win32 Console Application and that (Empty
project) is checked.

Once the project has been created, right-click on the project name in the solution window and select Set
as StartUp Project.



Add a file named main.cpp to the newly created project and type in the following code, again changing
the Author and the Class.

(d Y6 QuickLlaunch (Ctr
FILE EDIT VIEW PROJECT BUILD DEBUG TEAM  TOOLS TEST  ARCHITECTURE  AMALYZE  WINDOW  HELP
Q- B2 WM P Local Windows Debugger ~ - 5 - [

main.cpp main.cpp Solution Explorer
(Global Scope) @ main() & o-a
=) - -

1210(dxg 1amag

fa] Solution 'khoj0332Labs' (2 projects]
4 [% 01_1_HelloWorld
P 5 External Dependencies
"3 Header Files
™8 Resource Files
4 o] Source Files
B main.cpp
e <i sams 4 [%] 01_2_PayCalculator
b o5 External Dependencies
std; 8 Header Files
. "8 Resource Files
main L) 4 ] Source Files

4 main.cpp

xog|oo |

hours, rate, pay;

cout << "How many hours did you w
cin >» hours;

cout << "How much do you get paid per hour?
cin >» rate;

ay = hours * rate;
¥

cout << "You have earned §" << pay << endl;

100 % -
Output
Show output from: Build - é
cr maLil.vpp N
1> @1_1_HelloWorld.wvcxproj -* c:lusersishereen‘documents\visual studio 2813\Projectsi\khc
81_2_PayCalculator.vexproj - c:\users\shereen\documents\visual studioc 2813\Projects)
Build: 2 succeeded, 8 failed, @ up-to-date, @ skipped

3

Error List Pending Changes Team Expl... Class View

Build succeeded

Build and run your program.
Write a brief description of what the program does.

A

Show your completed work to the TA or the professor.




Save the project to your folder on grace and then place a copy of your project in the CS150-01
Drop folder!

8. Copy your solution PUNetIDLabs from Computer->Local Disk (C:)->Users-
>PUNetID->My Documents->Visual Studio 2013->Projects into your
individual folder in the CS150-02Accts folder on grace.

9. Copy your solution PUNetIDLabs into the CS150-02 Drop folder. This is how you will submit
your programming assignments in this course.

10. Once you have copied both projects to the proper location, stop and show your instructor or TA.

» After each lab session, be sure to copy your work to your folder on grace.

» As you work on your programming assignments, be sure to copy your work to your folder on grace.

Why is it so important to copy your work to grace?

» Optional Challenge (you do not need to submit this to CS150-02 Drop)
Once you have followed all of the above instructions and submitted your lab project, modify your pay
calculator so that it displays a message asking for a name. Once the user types in the name, the program

should display “Hello” followed by the name typed in by the user and then continue on with its
previous work. HINT: Look at the program at the end of the handout for Monday’s Lecture.

The updated input and output of the pay calculator should be as follows:
What is your name? Bob

Hello Bob!

How many hours did you work? 10



